Rails4.0.0beta1になってからvalidatesのformatも厳しくなった

セキュリティ的にも堅固になったと聞いてたんですが、Rails3.2.8→Rails.4.0.0.beta1のアップデートすると下記のエラーがでるようになった。

The provided regular expression is using multiline anchors (^ or $), which may present a security risk. Did you mean to use \A and \z, or forgot to add the :multiline => true option?

(さらに…)

続きを読む